UVA online Judge Solution -10055 - Hashmat the brave warrior by C - Code Solve 01

Latest

Saturday, May 5, 2018

UVA online Judge Solution -10055 - Hashmat the brave warrior by C

URI Online Judge | 11155

Hashmat the brave warrior


Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before Fighting he just calculates one thing, the difference between his soldier number and the opponent’s soldier number. From this difference he decides whether to fight or not. Hashmat’s soldier number is never greater than his opponent.

Input
The input contains two numbers in every line. These two numbers in each line denotes the number soldiers in Hashmat’s army and his opponent’s army or vice versa. The input numbers are not greater than 232. Input is terminated by ‘End of File’.

Output
For each line of input, print the difference of number of soldiers between Hashmat’s army and his opponent’s army. Each output should be in seperate line.

Sample Input
10 12 
10 14 
100 200

Sample Output
100

Solution in C language:

#include <stdio.h>

int main()
{
    long long int a, b;
    while(scanf("%lld %lld", &a, &b) != EOF)
    {
        if(a > b)
            printf("%lld\n", a - b);
        else
            printf("%lld\n", b - a);
    }
    return 0;
}

 

No comments:

Post a Comment